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1 Welcome

Welcome to ACR's TrendReader for SmartButton.

TrendReader for SmartButton, ACR's data analysis and graphing software, has been designed for the ACR
SmartButton miniature temperature data logger. This powerful, versatile and easy to use software program
enables logged data to be collected and thoroughly analyzed in seconds.

Key Features
 

 Simple logger setup
 Presentation quality graphs
 Multi-graph display (display graphs from different SmartButtons, or from different time periods, within
the same graph)
 Zooming capabilities
 Exporting capabilities

Data recorded by the SmartButton can be downloaded and viewed in table format, permitting detailed
analysis, or in graphical format for added presentation power. TrendReader for SmartButton allows you to
change graph colors, zoom in on specific portions of data, and print to any Windows compatible printer
with ease.

Use the export function in TrendReader for SmartButton to export your data to other programs for further
analysis. Data can be exported into ASCII, CSV, BMP, JPG or PDF formats.

Distributed by MicroDAQ.com, Ltd.                   www.MicroDAQ.com                   (603) 746-5524



5Welcome

© ACR Systems Inc.

1.1 About ACR Systems Inc.

ACR Systems offers a complete line of compact Data Loggers to measure and record temperature, relative
humidity, electric current, pressure, process signals, pulse frequency, power quality and more. ACR Data
Loggers have flown with airline pilots, raced with Indy drivers, driven with truckers and have even been into
outer space. ACR Loggers can be placed on top of, under and in buildings; they operate in tropical and
sub-zero temperatures, in and out of water and in just about any place imaginable. 

ACR Systems continues to be customer-driven, using its research and development expertise to accept
challenges others prefer to avoid. As a result, ACR remains on the leading edge of technological
advancements with simple, cost efficient and state-of-the-art, Technology-based products. Each ACR
product will further the tradition of maximizing safety, increasing efficiency and solving problems overdue for
solution. ACR products continue to be refined and improved to provide customers with innovative ways to
do the job better, faster and more efficiently.

To learn more about ACR Systems' Data Logging Products and Solutions, visit the ACR Systems website
at http://www.acrsystems.com.

1.2 Mailing Address

ACR Systems Inc.,
Unit 210 - 12960 84th Ave.
Surrey B.C., V3W 1K7
Canada

Phone: 1.604.591.1128
Toll Free in North America: 1.800.663.7845
Fax: 1.604.591.2252
E-mail: info@acrsystems.com
Customer Support: customerservice@acrsystems.com
Web Address: www.acrsystems.com

Distributed by MicroDAQ.com, Ltd.                   www.MicroDAQ.com                   (603) 746-5524
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1.3 Registering Your Software

After entering your serial number in TrendReader for SmartButton, you will be asked if you want to register
your software. Clicking "Yes" will take you directly to the registration page on the ACR Systems Inc.
website. Or you can register your software now by clicking here.

Registration benefits include:

 Ensuring you have purchased a quality, authentic ACR software product
 Allows you to receive notifications of new software products, upgrades and free software updates
 If you lose your serial number, we can provide it without proof of purchase
 Faster customer service - no contact info needs to be logged

1.4 Software Updates

Make sure your software stays current...

Visit us at www.acrsystems.com to download and install the latest software enhancements and updates
free of charge.
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1.5 TrendReader for SmartButton License Agreement

ACR TRENDREADER FOR SMARTBUTTON LICENSE AGREEMENT

CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS. IF YOU ARE PREPARED TO
ACCEPT THESE TERMS AND CONDITIONS PLEASE INDICATE THIS BY CLICKING THE “I ACCEPT”
BUTTON WHEN INSTALLING THE SOFTWARE. YOU WILL NOT BE ABLE TO COMPLETE THE
INSTALLATION OR USE THE ACR SOFTWARE SUPPLIED IN ASSOCIATION WITH THESE TERMS
AND CONDITIONS AND ANY THIRD PARTY SOFTWARE EMBEDDED IN THAT SOFTWARE
(COLLECTIVELY THE “SOFTWARE”) UNLESS YOU ACCEPT THESE TERMS AND CONDITIONS.  YOU
SHOULD CONTACT ACR IF YOU HAVE ANY QUESTIONS OR CONCERNS ABOUT THESE TERMS
AND CONDITIONS. IF, PRIOR TO COMPLETING INSTALLATION OF THE SOFTWARE, YOU DECIDE
YOU ARE UNWILLING TO ACCEPT THESE TERMS AND CONDITIONS, INDICATE YOUR DECISION BY
CLICKING ON THE “I DO NOT ACCEPT” BUTTON. THE INSTALLATION OF THE SOFTWARE WILL
CEASE AND YOU MAY RETURN THE SOFTWARE AND ANY ACR DATA LOGGER YOU PURCHASED
IN CONJUNCTION WITH THE SOFTWARE IN ACCORDANCE WITH ACR'S THEN CURRENT RETURN
POLICY. ACR CAN BE REACHED AT:
 
ACR Systems Inc.,
#210 - 12960 84th Ave., Surrey B.C., Canada  V3W 1K7
Phone: 1-800-663-7845 (North America toll free) or 1-604-591-1128
Fax: 1-604-591-2252
E-mail: info@acrsystems.com
Website: www.acrsystems.com
 
IF YOU DECIDE TO ACCEPT THESE TERMS AND CONDITIONS BY CLICKING THE “I ACCEPT”
BUTTON WHEN INSTALLING THE SOFTWARE, ENTER THE SERIAL NUMBER KEY PROVIDED TO
YOU, EITHER WITH ANY MEDIA THAT YOU PURCHASED WITH THE SOFTWARE OR BY ANY OTHER
APPROVED METHOD FROM ACR OR A RESELLER OF ACR, IN ORDER TO OBTAIN FULL USE OF
THE SOFTWARE. IF YOU HAVE LICENSED MORE THAN ONE COPY OF THE SOFTWARE, USE
SEPARATE SERIAL NUMBER KEYS PROVIDED TO UNLOCK EACH COPY OF THE SOFTWARE THAT
YOU HAVE LICENSED.

SOFTWARE LICENSE AGREEMENT

1. LEGAL AGREEMENT
THIS IS A LEGAL AGREEMENT BETWEEN YOU AND ACR SYSTEMS INC. (“ACR”). Please treat it as
valuable property.
 
2. OBTAINING SOFTWARE ON A FREE TRIAL OR PAID BASIS
This Software License Agreement provides a license of the Software (under paragraph 4 below) either: (a)
on a limited time trial basis, if you have obtained the Software free of charge from ACR or an authorized
reseller of ACR (a “Reseller”) by means of a Software trial program authorized by ACR (a “Trial Basis”); or
(b) on a paid basis if you have paid ACR or a Reseller for the Software (a “Commercial Basis”).
 
3. OWNERSHIP OF SOFTWARE
The Software and Documentation is licensed and not sold to you. This Agreement does not convey to you
any ownership right, interest or title in or to the Software, or to any related intellectual property rights. 
 
4. GRANT OF LICENSE(S)  
Subject to the terms and conditions set out in this Agreement and of your paying any necessary fees for
the Software:
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(a) if you have obtained the Software on a Trial Basis, ACR hereby grants to you, for each item of Software
provided to you, a temporary, personal, non-exclusive, non-transferable, royalty free license to install and to
use the object code on no more than one personal computer at any given time solely for the purpose of
determining whether the Software is suitable for your purposes, and to use the documentation supplied with
the Software (the “Documentation”) solely in connection with this use, all for a limited period of 30 days (the
“Trial License”); and
(b) if you have obtained the Software on a Commercial Basis, ACR hereby grants to you, for each item of
Software provided to you, a personal, non-exclusive, non-transferable license to make the number of copies
of the Software for which you have paid the applicable fees, and for which you have received separate Serial
Number Keys and to install and to use the object code for each authorized copy of the Software on no
more than one personal computer at any given time, and to use the Documentation solely in connection
with this use.If you have obtained the Software on a Trial Basis, the Trial License will automatically
terminate 30 days after first 
installing the Software and you will not be permitted to use the Software after that time. ACR reserves the
right, in respect of Software provided to you on a Trial Basis, to require that any media that the Software
has been provided on and all Documentation provided be returned to ACR within 20 days after termination
of the Trial License and all additional copies of the Software in your possession be destroyed immediately
after termination of the Trial License.
 
5. RESTRICTIONS  
You shall not: (a) use the Software except as expressly permitted in this Agreement and for the purposes
contemplated by the Documentation; (b) redistribute or authorize or acquiesce in the use of the Software
by any third party (other than consultants who need to use the Software in order to perform services on
your behalf); or (c) attempt to defeat any protection method designed to prevent the unauthorized use of the
Software. You shall not copy or reproduce the Software except as expressly authorized in paragraph 4 and
except to make one archival copy to be stored in a secure location and used for back-up purposes only.
For the purposes of this provision, “copy” shall not include copying that naturally results from the
authorized use of the Software or in the course of making regular back-ups of the computer or system on
which the Software is installed.
 
6. CONFIDENTIALITY
The Software and Documentation contains information that is confidential and proprietary to ACR. Upon
receipt of your written request, ACR shall provide you with any information about the Software in its
possession or control that you require to operate the Software in conjunction with any other software or
equipment that you use in your business. You shall not: remove any notices, labels or marks from the
Software; deliver, disclose, convey, either directly or indirectly, the contents of the Software to any third
party; or alter, modify, translate, decompile, disassemble, or reverse engineer the whole or any part of the
Software, without first obtaining the express written consent of ACR.
 
7. DISCLAIMER
ACR PROVIDES ANY SOFTWARE, DOCUMENTATION AND ASSISTANCE (AS DEFINED BELOW) TO
YOU ON AN “AS IS” BASIS. ACR MAKES NO REPRESENTATIONS, WARRANTIES, CONDITIONS OR
COVENANTS WHATSOEVER, EITHER EXPRESS OR IMPLIED, (INCLUDING, WITHOUT LIMITATION,
ANY IMPLIED WARRANTIES OR CONDITIONS OF FITNESS FOR A PARTICULAR PURPOSE,
MERCHANTABILITY, PERFORMANCE, DURABILITY, TITLE OR NON-INFRINGEMENT) WITH RESPECT
TO ANY SOFTWARE, DOCUMENTATION OR ASSISTANCE PROVIDED TO YOU. YOU AGREE TO
ASSUME ALL RISKS ASSOCIATED WITH YOUR USE OF THE SOFTWARE AND DOCUMENTATION.
Without limiting the generality of the foregoing, ACR does not warrant that the Software will operate on a
continuous and trouble free basis and in no event shall ACR be responsible for any problem with the
Software or damage caused by the Software, 
including, without limitation, problems or damage due to: (a) modiications of the Software; (b) its use in
association with other software or hardware that the Documentation does not speciically indicate the
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Software is compatible with; (c) its use in a manner or for an activity not contemplated by the
Documentation; (d) electrical 
supply, wiring or network problems; (e) the improper installation of the Software; (f) abnormal environmental
conditions; (g) a failure to install any bug ix supplied by ACR; or (h) the wilful or negligent acts of any
person other than ACR or its agents. You are responsible for selecting the software that will achieve your
desired results, and for the installation, use and results obtained from the Software. ACR may provide
limited technical assistance (“Assistance”) to You as determined by ACR in its sole discretion from time to
time.
 
8. LIMITATION ON LIABILITY
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL THE
AGGREGATE LIABILITY OF ACR, ITS SUPPLIERS AND RESELLER TO YOU EXCEED THE AMOUNT
YOU HAVE PAID TO ACQUIRE THE SOFTWARE, AND IN NO EVENT SHALL ACR, ITS SUPPLIERS,
OR RESELLER BE LIABLE FOR ANY INDIRECT, INCIDENTAL, CONSEQUENTIAL, OR SPECIAL
DAMAGES, INCLUDING WITHOUT LIMITATION ANY DAMAGES FOR LOST PROFITS OR SAVINGS,
REGARDLESS OF WHETHER THEY HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE. EXCEPT TO THE EXTENT THAT THE LAWS OF A COMPETENT JURISDICTION REQUIRES
LIABILITIES BEYOND AND DESPITE THESE LIMITATIONS, EXCLUSIONS AND DISCLAIMERS, THESE
LIMITATIONS, EXCLUSIONS AND DISCLAIMERS SHALL APPLY WHETHER AN ACTION, CLAIM OR
DEMAND ARISES FROM A BREACH OF WARRANTY OR CONDITION, BREACH OF CONTRACT,
NEGLIGENCE, STRICT LIABILITY OR ANY OTHER KIND OF CIVIL OR STATUTORY LIABILITY
CONNECTED WITH OR ARISING FROM THIS AGREEMENT.
 
9. TERMINATION FOR BREACH OF AGREEMENT
The Software is protected by copyright laws and International treaty provisions.There are severe penalties,
both civil and criminal, for copyright infringement. Any breach of this Agreement could cause ACR
irreparable harm. If you fail to comply with any of the terms of this Agreement, all licenses granted
hereunder shall automatically terminate without notice, and ACR may exercise any or all of its rights under
this Agreement or under applicable law, including without limitation, obtaining relief by way of a temporary
or permanent injunction. Upon termination of this Agreement, and in any event upon ACR delivering you
notice of termination for breach, you shall immediately purge all Software from your computer system(s),
and return all copies of the Software and Documentation in your possession or control to ACR.  
 
10. PERSONAL INFORMATION 
By submitting personal information, including, without limitation, your contact information and information
about the specific ACR products you have purchased or licensed in connection with this Agreement (your
“Personal Information”) to ACR, its Resellers, agents or affiliates (collectively the “ACR Group of
Companies”), you agree that any such party may collect, use, and/or disclose your Personal Information in
accordance with ACR's privacy policy (which may be viewed at www.acrsystems.com/privacy/ and which is
subject to modification at any time by ACR in ACR's sole discretion) and for the following purposes: (a) to
provide customer service assistance, including to communicate with you, to facilitate service, rebates, and
returns, and to conduct surveys, contests, and promotions; (b) to develop, enhance, market, sell, provide,
and inform you of products and services developed, produced or sold by any of the ACR Group of
Companies or by a third party with whom ACR has a commercial relationship, including to conduct
research and statistical analysis; (c) to monitor communications to ensure the consistency and quality of
the products and services of the ACR Group of Companies and other third parties with whom ACR has a
commercial relationship; (d) for any purpose otherwise permitted by law; and (e) for any other purpose to
which you consent. You may view your Personal Information and, subject to legal and contractual
requirements, you may refuse or withdraw your consent to certain of the purposes listed above at any time
by contacting ACR. You further agree that we may provide your Personal Information to other persons as
required to satisfy any legal requirements and to any person that purchases all or a substantial portion of
ACR's assets or participates in a merger or substantial reorganization of ACR's business, provided that
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such person agrees to use your Personal Information only in accordance with terms and conditions that are
no less protective of your Personal Information than the terms and conditions contained in this paragraph
10.
 
11. MISCELLANEOUS
Paragraphs 5, 6, 7, 8, 9, and 11 shall survive termination or expiration of the license(s) granted hereunder.
When used in this Agreement, the term “license” shall be deemed to include “sub-license” for items of third
party software embedded in the Software. This Agreement constitutes the entire agreement of the parties
with respect to the Software, and supercedes all prior communications, agreements and discussions
between the parties. It will be governed by the laws of the Province of British Columbia, and the laws of
Canada applicable therein, excluding any rules of private international law that lead to the application of the
laws of any other jurisdiction. The United Nations Convention on Contracts for the International Sale of
Goods (1980) does not apply. The courts of the Province of British Columbia shall have non-exclusive
jurisdiction to hear any matter arising in connection with this Agreement. If any provision of this Agreement
is void or is declared void, the provision shall be severed from this Agreement, which shall otherwise remain
in full force and effect. 

Upon installing the Software:
Indicate acceptance of the license terms and conditions by selecting: I ACCEPT
If the terms and conditions are not acceptable to you, select: I DO NOT ACCEPT
 
To download a copy of this License Agreement in PDF format, click here.
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2 Introduction to SmartButton

The ACR SmartButton is an extremely robust, miniature sized, single channel
temperature data logger. Its durable construction makes it the ideal product for
unforgiving environments.

The SmartButton is designed to work simply and effectively with ACR's TrendReader for
SmartButton software.

Features:

ACR SmartButton measures temperature in 0.5°C increments
Logs up to 2048 consecutive temperature measurements in internal memory
Programmable temperature-high and temperature-low alarm trip points
Records up to 24 time stamps and durations when temperature leaves the range specified by the trip
points (12 periods for too hot and 12 for too cold)
Automatically wakes up and measures temperature at user-programmable intervals from 1 to 255
minutes

Next: Specifications

2.1 Specifications

General Specifications

Size: 17.35mm diameter x 5.89mm height (0.68” x 0.23”)
Weight: 4 grams (0.14 ounces)
Case Material: Stainless Steel 
Battery: 3.0 volt Lithium – Approximate 10 year battery life using 20 min 

sample rate at 15°C (*See product lifetime table for more information)
Resolution: 8-bit (1 part in 256)
Mounting: User selectable (magnetic backing, plastic plate mount, angled blue 

hard plastic or self-adhesive backing material) 
Clock Accuracy: ± 2 minutes per month from 0° to 45°C (32° to 113°F)
Sampling Methods: Continuous (First-in, First-out) or Stop When Full (Fill-then-stop) 
Operating Limits: -40°C to 85°C (-40°F to 185°F)
PC Requirements: Windows PC with at least one free USB Port
Software Requirements: ACR TrendReader for SmartButton Software
Communication: USB/ACR SmartButton Interface

Temperature Sensor Specifications

Type: Silicon
Range: -40°C to 85°C (-40°F to 185°F)
Accuracy: ±1.0°C from -30°C to 45°C (± 1.8°F from -22°F to 113°F) 

±1.5°C from 45.5°C to 85°C (± 2.7°F from  114°F to 185°F)

Warranty: 1 Year

Next: Introduction to TrendReader for SmartButton
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3 Introduction to TrendReader for SmartButton
This chapter describes the minimum system requirements necessary to run TrendReader for SmartButton and

will guide users through installing the application.

Next: System Requirements

3.1 System Requirements

TrendReader® for SmartButton System Requirements:

Pentium 1GHz or faster processor
Windows XP SP3, Windows Vista* SP2 (32 bit or 64 bit) or Windows 7* (32 bit or 64 bit) - *Home
Premium, Business or Ultimate Editions
250MB of available hard drive space
512MB of RAM (1GB recommended)
Optical drive (for installing from CD-ROM)
Available USB port
Mouse or other pointing device
Internet Explorer 6 or higher
Screen resolution of 1024 X 768 or higher for optimal viewing results

NOTE: All user accounts with read/write access to the TrendReader® for SmartButton application folder will

have full access to TrendReader® for SmartButton, however only an administrative user with full access will
be able to install the application. If you are unsure whether or not you have administrative access to your
computer, please consult with your system administrator before proceeding with the installation.

Next: Installing TrendReader for SmartButton
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3.2 Installing TrendReader for SmartButton

Before starting the installation, it is recommended that you disconnect all data logger cables
from your computer and close all other applications.

To install TrendReader for SmartButton, insert the Installation CD into the optical drive of your computer. The

installation should start immediately, w ith the following window popping up briefly.

A w indow will appear asking which language you want to select for the installation process. Note: The language

chosen here is used during the installation process only. The actual language TrendReader for SmartButton

uses is based on your system’s regional settings. Click on the appropriate language, and then click Next to

continue. Clicking Cancel at any time will abort the installation.

Distributed by MicroDAQ.com, Ltd.                   www.MicroDAQ.com                   (603) 746-5524
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A window indicating that the InstallShield Wizard is being prepared will be shown briefly and then disappear. No

action is required.

A window welcoming you to the installation of TrendReader for SmartButton will then appear. Click Next to

continue.
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The license agreement w ill then be displayed. Ensure that you read the terms and conditions thoroughly. To

print a copy of the license agreement, click the Print button. Before you can proceed with the installation, you

must accept the terms of the license agreement and click Next to continue.
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In the next screen, enter your User Name, Company Name, and the Serial Number of the software. If you have

purchased your software, the serial number can be found on the back of the CD sleeve. Please keep the serial

number in a safe place for future use.
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If you have acquired a trial version of the software, enter TRIAL to install the software as a 30-day trial version.

Note that the trial version can only be installed once and will require a serial number in order to function after

the 30 day trial has expired. Click Next to continue.
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In the next screen, you select the setup type. For the initial installation, a Complete setup is recommended.

Choosing a Custom setup would allow you to select the installation drive or folder.
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The wizard is now ready for installation. Click Install to begin the installation.
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Depending on the speed of your computer, the installation may take several minutes to complete.
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Once the installation is complete, click Finish.
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Next: TrendReader for SmartButton - User Interface

4 User Interface
TrendReader for SmartButton has a standard, easy-to-use interface.

Following are the components of the user interface:

Title Bar

Menu Bar

Toolbars

Work Area
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4.1 Title Bar

The Title Bar shows the name of the software and contains the minimize, maximize, restore and close buttons.

You can minimize the TrendReader for

SmartButton application by clicking on the

minimize button as shown to the right.

   

There are several ways to resize the

TrendReader for SmartButton application

window. If the w indow is maximized, click

on the restore button as shown to the

right. This w ill restore the w indow to its

previous size before it was maximized. You

can then also drag the edges and corners

to resize the w indow.

   

To maximize the w indow again, click on the

maximize button as shown to the right.

Also, double-clicking anywhere on the title

bar w ill alternately restore and maximize

the w indow.
   

To close the active w indow, click on the

close button as shown to the right. If the

active w indow is the main TrendReader for

SmartButton application w indow, clicking

the close button will exit the application.
   

Next: M enu Bar
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4.2 Menu Bar

This section provides an overview of the organization of menus in TrendReader for SmartButton. The menus

and the functions available are described in the following sections.

File Menu

The File Menu allows you to perform standard file and printing operations through the following selections:

Open, Recent Files, and Exit.

Open

Selecting Open from the File Menu pops up a standard Open file dialog box. From here, you select the file you

want to open. When a file is opened it is also graphed. You can choose from files w ith the .DLF, .SMT or .TRW file

extensions. When the file is opened, it w ill be displayed in the same condition in which it was last saved. For

example, if you had zoomed in on a section of the graph when you saved it, this is the way it w ill appear.

Recent Files

Selecting Recent Files from the File Menu brings up a list of the most recently used files. From here, simply

select the file you want to open.

Exit

Selecting Exit from the file Menu will close the application.
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Edit Menu

The Edit Menu allows you to perform the standard text editing functions, Copy and Select All.

Copy

Selecting Copy from the Edit Menu will copy the highlighted text to the Clipboard.

Select All

Choosing Select All from the Edit Menu will select or highlight all the text in a field. You can then Copy the text.

View Menu

The View Menu allows you to select which Toolbars are to be displayed.

Toolbars

You can enable toolbars for various functions by selecting Toolbars from the View Menu. Available toolbars are

File, Edit, View, Tools, and Help.
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Message Logs

You can use the message Logs menu item to view all messages saved from the Status Log and Diagnostic Log

to assist w ith any troubleshooting. The message logs is a data file that stores all Status Log and Diagnostic Log

messages from the initial installation of TrendReader.
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Tools Menu

In the Tools Menu, you can launch a variety of utilities that help you configure TrendReader for SmartButton,

including: Logger List, Change Units, and Preferences.

Selecting Logger List from the Tools menu will launch the Edit Settings w indow where you can edit logger

names or delete loggers from the system.

Click on a logger name to pop up the Logger Name form. To edit the logger name, click in the text field and type

the new name. Click OK to accept the changes. Click Delete if you want to remove the logger from the system.

To save the changes to the system, you can either click on Apply or OK in the Edit Settings w indow. OK will

implement the changes and close the w indow whereas Apply w ill leave the w indow open, thereby allowing you

to make other changes.
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Change Units

Selecting Change Units from the tools Menu will launch the Preferences window and take you to the Axis tab of

the default Graph Template screen. You can then select which units to use for your graph and Realtime

readings.

Preferences

Selecting Preferences from the Tools Menu will launch the Preferences window where you can configure how

you want TrendReader to appear.
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Actions Menu

The Actions Menu provides you with various tools for functions that work w ith data loggers and connections.

The items available in the menu depend on what has been selected in the Shortcuts Bar.

As an example of the actions available, when an available connection is selected there are selections for

Scanning for Loggers, Closing the Connection, Editing Properties, and Refreshing the Connection.

Help Menu

The Help Menu allows you to access standard help and product related functions, including: displaying the Help

Manual (contents or search function), entering the License Serial Number, and displaying the software version.

Next: Toolbars
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4.3 Toolbars

This section provides an overview of the organization and use of toolbars in TrendReader for SmartButton. The

toolbars and the functions available are described in this section.

By selecting Toolbars from the View Menu, you can enable toolbars for File, Edit, View, Tools, and Help

functions. The toolbars allow you quick access to commonly performed actions (such as those also available

through the File Menu). Simply click on the toolbar's icon to execute the function. They can be docked almost

anywhere in the w indow, including over the work area. You can select text to be displayed beside the icons and

enable tooltips from Preferences in the Tools Menu.

File

Toolbar

Edit

Toolba

r

View

Toolbar

Tools Toolbar Help Toolbar

File Toolbar

The File Toolbar allows you to open a previously saved data logger file (.dlf).

Edit Toolbar

The Edit Toolbar allows you to any selected text to the clipboard.

View Toolbar

The View Toolbar allows you to open the Message Logs window, where you can view all messages saved from

the Status Log and Diagnostic Log to assist w ith any troubleshooting.

Tools Toolbar

From the Tools Toolbar, you can launch a variety of utilities that help you configure TrendReader for

SmartButton, including: Logger List, Change Units, and Preferences.

Help Toolbar

The Help Toolbar provides you with access to TrendReader for SmartButton's online help. From the Help

Toolbar, you can also enter or update your License Serial Key. If you have installed the application as a Trial, you

must enter a License Serial Key after 30 days of use.

Next: Work Area
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4.4 Work Area

The Work Area shows the detail of the items selected in the Shortcuts Bar. For example, if you have contacted a

logger, the Work Area w ill show the status for that logger. Buttons for the functions available, essentially the

Actions Toolbar, are shown at the top of the Work Area. The title of the Work Area w ill reflect the selection from

the Shortcuts Bar. In this example, the logger type and serial number are shown in the title.

 

The Status Log displays the actions that the application is performing. The results of these actions are shown

in the Status Log window and can be used to determine if an action was completed.

Next: Preferences
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5 Preferences
The Preferences window (accessible from the Tools Menu or the Tools Toolbar) is where you can configure

how you want TrendReader to appear.

Next: Basic Settings
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5.1 Basic Settings

In the Preferences tree, selecting Basic Settings provides you with 2 tabs, one for Basic Options and one for

Menus and Toolbars.

Basic Options

From the Basic Options tab, you can set whether you want to Enable Tooltips (mouse-overs), enable or disable

the entry of Backup Settings while backing up your SmartButton logger, or whether or not you want to enable a

graph to open automatically immediately following backup. Realtime options include whether or not the

Realtime Window always appears on top of other w indows. You also have the option of combining individual

Realtime Display w indows into a single w indow and whether or not to display Realtime Alarms.

Menus and Toolbars

Within the Menus and Toolbars section of the Basic settings, you set how you want the program to appear. For

the Look and Feel, select a style from the drop-down list. To select the number of Recent Files to display, use

the up and down buttons to scroll from 0 to 5 files. If you select Image and text as a Toolbar Style, icons will be

displayed with an image and a description of the function, otherwise, only the image is shown. You can also

choose either a small or large size for the Toolbar.
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Next: Data Folder
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5.2 Data Folder

Data Folder

In the Data Folder section under Preferences, you can set the default location for storing your saved

SmartButton data files (.dlf). Clicking the Restore Default button will set the target folder location to the default

location. Click the Change button to browse for and select a new folder for storing data files. To see the files in

the Data Folder, click on Find Target.

*Note: The changes will only be implemented if you click on either Apply or OK. Clicking on OK will implement

the changes and close the Preferences window whereas clicking on Apply w ill leave the Preferences window

open, allowing you to make changes to other features.

Next: Display Templates
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5.3 Display Templates

Display Templates

The Display Templates section allows you to create and manage templates that are used to format graphs and

Realtime units. You can use the factory default template or you can create your own custom templates. 

*Note: The template changes will only be implemented if you click on either Apply or OK. Clicking on OK will

implement the changes and close the Preferences window whereas clicking on Apply w ill leave the

Preferences window open, allowing you to make changes to other features.
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New Template
1.  To add a new template, click on New to pop up a name form.
2.  Enter the name and click OK.
3.  Select a template to use as the basis for your new graph template. choose either the factory default template

or a previously created custom template (If one is available)

Rename
1.  To rename a template, highlight the template in the main screen.
2.  Click on Rename to pop up a name form.
3.  Enter the name and click OK.

Edit
1.  To edit a template, highlight the template in the main screen.
2.  Click on Edit to replace the Templates Window with the Graph Settings Window.

Delete
1.  To delete a template, highlight the template in the main screen.
2.  Click on Delete to pop up a confirmation form.
3.  Click Yes if you are sure you want to delete the template. The template w ill be marked for deletion and will

be removed when you save the changes.

Set as Default
1.  To set a template as the default, highlight the template in the main screen.
2.  Click on Set as Default.

Next: Setting Graph Preferences
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5.3.1 Setting Graph Preferences

Setting Graph Preferences

When you click on a template name in the Graph Templates Tree, the Templates Window changes to the Graph

Settings Window. Click on the various tabs and set the listed properties as required. Available settings tabs are

General, Styles, Fonts, Colors, Lines, and Axis. Note that the Factory Template is "Read-Only" and cannot be

deleted, renamed or edited.

Next: Connecting and Communicating with SmartButton
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6 Connecting and Communicating with SmartButton
This section describes how to set up an initial connection w ith the SmartButton USB interface cable and the

SmartButton data logger.

Next: Scanning for Connections

6.1 Scanning for Connections

Connect the SmartButton USB cable to an available USB port on your computer and launch the TrendReader for

SmartButton application.

Before communicating w ith the SmartButton temperature logger, you must first scan for connections by

clicking the Scan for Connections button on the toolbar. 

After Scanning for Connections, an icon representing the SmartButton USB interface cable w ill appear in the

Connections panel on the left side of the w indow as shown below.
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Next: Scanning for Loggers
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6.2 Scanning for Loggers

After the SmartButton USB cable has been recognized, contact the SmartButton by clicking the Scan for Loggers

button. It may take several seconds to establish contact w ith the SmartButton.
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After establishing contact w ith the SmartButton by Scanning for Loggers, the connected SmartButton's status

will appear in the main w indow.

To view more detailed information related to the SmartButton data, you can expand the Status and Channel

settings by clicking on the + sign.

Next: Configuring SmartButton Settings
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6.3 Configuring SmartButton Settings

Once the logger has been contacted and the logger status is visible, click on the Edit Setup button to pop up the

Edit Logger Setup form.

IMPORTANT: Applying new settings to the SmartButton will clear any and all data currently on the device. If you

wish to save and/or view any data currently recorded on the device, be sure to Backup the SmartButton before

making any changes to the setup.
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In the Edit Logger Setup w indow, you can edit the Description of the SmartButton (i.e. Pharmacy Refrigerator),

adjust the SmartButton's Sampling rate from 1-255 minute intervals, adjust the memory usage (i.e. Stop When

Full or First In, First Out), select a Start Time for the logger to begin recording, and set the high and low alarm

thresholds.

Click OK to apply the new settings and close the Edit Logger Setup window.  IMPORTANT: Applying new settings

to the SmartButton will clear any and all data currently on the device. If you wish to save and/or view any data

currently recorded on the device, be sure to Backup the SmartButton before applying any changes to the setup.

Once you have applied the new settings, you can place the SmartButton in the area where you would like it to

begin recording.

Next: Introduction to Realtime Display
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6.4 Introduction to Realtime Display

The SmartButton data logger takes samples and stores the readings in memory. To view all the stored data,

either as a graph or a data table, you need to backup the logger. However, while the SmartButton is connected

to your computer, you can view the current sample, known as the Realtime value or reading. You can use the

Realtime value to monitor current temperature conditions. 

The Realtime values are displayed in the logger status w indow in the Work Area. To display the current

Realtime information from your SmartButton logger in a pop-up window, click the Maximize Realtime button on

the toolbar directly above the Work Area. Information in the Realtime window will update w ith each sample

recorded by the SmartButton.

Next: Working with the SmartButton's Collected Information

7 Working with the SmartButton's Collected Information
This section explains how to view the SmartButton's recorded data on a graph or in tabular format.

Next: Backing Up and Viewing the SmartButton Data
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7.1 Backing Up and Viewing SmartButton Data

In order to view and analyze the SmartButton's collected data, you must first backup the SmartButton using the

following method. 

In the Logger Backup Settings window, you are able to change the Graph Title, Sub-Title or Filename.  Note: The

default Graph Title, Sub-Title and Filename is based on the SmartButton's serial number. 

Next: Opening a Saved Graph
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7.2 Opening a Saved Graph

To open and view a previously saved graph, click the Open button on the main toolbar.

Next select the .dlf (Data Logger File) you wish to open and click the Open button. The file name contains the

SmartButton serial number and the date the file was saved.
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The file w ill then open in a graph window. To view the recorded data in tabular format, select the Data Table tab

at the bottom left of the graph.

After selecting the Data Table tab, SmartButton data w ill appear in a table below the graph. Note: The data visible

in the graph will appear highlighted in blue in the table. You are able to view all of the data contained in the open

file in the table but only the data visible in the graph appears highlighted. Zooming in or out of the graph will

highlight the same information in the table view.
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You can arrange the graph and tabular information in a variety of ways by dragging the Data Table tab to the area

of the workspace you want to dock it in.

Next: The Graph Window

7.3 The Graph Window

Graphs are used to display the data recorded by the SmartButton logger. You can set an option in Preferences

to automatically display the graph when a SmartButton is backed up. When opening a saved data logger file (.dlf),

the Graph Window will appear displaying the data in both graphical and tabular formats.

Next: Opening M ultiple Graphs  

Distributed by MicroDAQ.com, Ltd.                   www.MicroDAQ.com                   (603) 746-5524



53Working with the SmartButton's Collected Information

© ACR Systems Inc.

7.4 Opening Multiple Graphs

By holding the control (Ctrl) key and selecting (single clicking on) 2 or more SmartButton (.dlf) files, you are able

to open and view multiple graphs in the same window. Note: If the loggers were recording during the same

sampling period (time-frame), they w ill automatically appear overlaid, thus allowing you to compare the

temperature recordings over the same time period.  If the loggers were recording at different times, the

graphs will appear side by side on a time line.

Click Open on the toolbar or from the File Menu to browse and select previously saved data files.

While holding the control (Ctrl) key, single click to select any number of saved SmartButton (.dlf) files. Once you

have chosen the data files you want to view, click Open.
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The image below displays data recorded over the same time frame by 2 different SmartButton loggers. 

Next: Zooming

7.5 Zooming

The Zoom Toolbar in the Graph Window provides you with the ability to magnify a section of the graph in order

to see it in greater detail. The Zoom Method Menu is used to select the style of the zoom (Box Zoom or

Horizontal Zoom) and also if you want to zoom in on specific dates and times. After zooming, if you want to

revert back to previous displays, use Unzoom Last or Unzoom All.
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Next: Exporting Data
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7.6 Exporting Data

In TrendReader for SmartButton, you have the ability to export the SmartButton data file into several other

formats. Select Save as type in the drop-down menu.

Data can be saved in the following textual and graphical file formats: CSV (Comma Separated Value), viewable in

Excel; TXT (common text file); BMP (bitmap image); JPG image; and PDF format containing the data table only,

graph only, statistics table only or a combination these.

Next: Troubleshooting
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8 Troubleshooting
Q. Why Can't I Open TrendReader for SmartButton?

A. Only one instance of TrendReader for SmartButton can be open at one time. If your computer has multiple

user accounts, ensure that another logged on user does not have TrendReader for SmartButton open.

Q. Why Can't I Communicate w ith my SmartButton?

A. If your SmartButton does not respond when communication is attempted, check that:

    1) The connection between the computer and the logger is secure

    2) The SmartButton is securely seated in the SmartButton USB interface cable and that the USB cable is

inserted securely into a USB port on your computer.

    3) The SmartButton USB interface cable is installed in your system's Device Manager. The device should

appear as a "1-Wire USB Host Adapter".

   

    If the logger still does not work, try:

    1) Another SmartButton USB interface cable

    2) Testing the interface cable and SmartButton on another computer

Q. Why Can't I Backup my SmartButton?

A. Check to see that the logger has a minimum of 3 readings, otherwise it w ill not backup as there is not

enough data.

    If the SmartButton has more than 3 readings and the software cannot backup the data, make sure there is

enough available space on the hard disk to store the data.

Q. How Accurate are the Time Measurements?

A. The SmartButton's clock is accurate to w ithin ± 2 minutes per month from 0° to 45°C (32° to 113°F)

Q. How Can I use TrendReader for SmartButton in Another Language?

A. TrendReader for SmartButton is a very flexible application that you can customize to your preferred language.

You can change the language by changing the operating system language. This is done through your system's

Regional Settings w ithin the Control Panel.

TrendReader for SmartButton supports the following languages:

English

French (Canadian)

Chinese (Simplified)

German

Japanese

Portuguese (Brazilian)

Portuguese (Standard)

Spanish

If a technical issue you are experiencing is not covered here, visit ACR Systems' Website or feel free to contact

our Technical Support Department.
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